Talk Talk - Webmail Issues

Major incident Webmail Email (IMAP)
2023-05-05 15:13 BST · 3 days, 6 hours, 45 minutes

Updates

Resolved

Webmail & IMAP Mail Client access is now working normally.

We’re really sorry for any inconvenience caused but thank those impacted for their patience and understanding.

If anyone is still having problems, please call our support team from 9am tomorrow morning on 01243 913 913.

May 8, 2023 · 21:57 BST
Issue

Our Email Engineers are aware of a problem with connecting to www.toolkitwebmail.co.uk through Talk Talk internet services.

We’re also aware of, in a few cases, of Talk Talk blocking IMAP connections through Mail Clients.

We’re so sorry for this, but our engineers at Rackspace are liaising with Talk Talk to resolve this and get Webmail and IMAP services back to normal.

We’ll keep this page updated as and when we hear more.

For those impacted, we recommend connecting to the internet through a 4/5G connection or through a different WiFi/network so emails can be sent and received.

We’re really sorry for any inconvenience caused just before the long bank holiday weekend.

May 5, 2023 · 15:13 BST

← Back