Toolkit Broadcast - Down

Major incident Toolkit Broadcast
2023-06-28 17:41 BST · 2 hours, 27 minutes

Updates

Resolved

Toolkit Broadcast is operating normally once more.

We’re sorry for any inconvenience this temporary down time may have caused.

June 28, 2023 · 20:08 BST
Issue

We’re aware that Toolkitbroadcast.co.uk is current unavailable.

Our engineers are working on a solution and we’ll update this status once we know more.

We’re sorry for any inconvenience caused.

June 28, 2023 · 17:41 BST

← Back