Toolkit Webmail - Login Error

Minor incident Webmail
2024-04-02 12:10 BST · 1 hour, 19 minutes

Updates

Resolved

Normal service has been resumed for all Webmail users.

We apologise for the inconvenience caused by this temporary outage.

April 2, 2024 · 13:29 BST
Issue

We are aware that some clients are having difficulties logging in to their Webmail service with us.

We’ve raised this with our Email Engineers who are working on a fix.

We’re really sorry for any inconvenience caused and will update this page with more information as this develops.

April 2, 2024 · 12:10 BST

← Back