Toolkit Webmail - Unavailable

Minor incident Webmail
2024-05-03 15:27 BST · 2 hours, 41 minutes

Updates

Resolved

Toolkit Webmail is now working normally again.

We’re really sorry for the inconvenience this may have caused.

May 3, 2024 · 18:08 BST
Investigating

Toolkit Webmail is currently unavailable:

https://www.toolkitwebmail.co.uk/

Our Rackspace email engineers are working on a fix to get normal service resumed asap.

We will update this page as soon as we know more.

Email services are unaffected, with IMAP connections on mobile phones, mail clients and tablets working normally.

If you need to send and receive emails, please use a mail client like Outlook, Thunderbird or Mac Mail, or if you’re on the go, use your emails on your iPhone or Android native email apps.

See more info here on how to set these up:

https://www.toolkitsupport.uk/setup-your-emails

May 3, 2024 · 15:27 BST

← Back