OX Webmail - Offline

Minor incident Webmail
2025-06-18 18:52 BST · 45 minutes

Updates

Resolved

Webmail is back online & working normally.

We apologise for the temporary down time.

June 18, 2025 · 19:38 BST
Issue

OX Webmail is currently offline via:

https://eu.appsuite.cloud/appsuite/

Our OX engineers are aware of the issue and are working on getting Webmail back online and operational again.

We’re really sorry for this down time, please note that email services on IMAP connections, such as phones, tablets and mail clients like Outlook & Thunderbird are working normally.

Please subscribe to this status page for more information as and when it becomes available.

June 18, 2025 · 18:52 BST

← Back