Webmail Login - Investigating

Minor incident Webmail
2025-07-23 08:57 BST · 3 hours, 36 minutes

Updates

Resolved

Webmail & IMAP login has been restored for all users.

If you continue to have any issues, please contact our team on 01243 913 913.

We’re sorry for any inconvenience this caused.

July 23, 2025 · 12:33 BST
Monitoring

After further investigation it seems the issue was around Username & Password authentication when logging in to Webmail or IMAP connections.

We’ve since been able to replicate and fix this for all the affected users we are aware of.

For any still impacted, please login again to Webmail and if required, wait 2-3 minutes for the login window to process:

https://eu.appsuite.cloud/appsuite/

Once logged in you will see all emails as they were not impacted during this period of login downtime.

If any users are still unable to login or use their emails normally, please contact our team on 01243 913 913 urgently.

We will keep this status open as we monitor the recent fix.

July 23, 2025 · 09:51 BST
Investigating

We’ve been made aware of issues with OX Webmail Login.

We cannot replicate it in our office and Open X-Change have yet to confirm they are aware of the issue, however we’re continuing to test and will update this page when we have more information.

It is seemingly only impacting a small number of our clients so for those affected, please look to use emails via IMAP connections as per:

https://www.toolkitsupport.uk/setup-emails-OX

We recommend Thunderbird for Desktop devices:

https://www.thunderbird.net/en-US/thunderbird/all/

We’re really sorry for the inconvenience this has caused and will seek to update this page ASAP once we know more this morning.

Call our team on 01243 913 913 for more information or help setting up on IMAP connections.

July 23, 2025 · 08:57 BST

← Back