Mobile Webmail Unavailable

Major incident Webmail
2020-09-04 09:26 GMT · 3 days, 1 hour, 2 minutes

Updates

Resolved

We’re delighted to confirm Toolkit Webmail is now working again on Mobile Phone Browsers.

We’re sorry for the issues experienced over the weekend.

We’ll be working to improve the login screen over the coming days, but you can now access www.toolkitwebmail.co.uk on your phone and login as normal.

If anyone has any further issues please don’t hesitate to contact us on support@toolkit.uk or call our team on 02380 633644.

November 4, 2021 · 15:24 GMT
Issue

We’re aware of an issue for Toolkit Webmail on mobile phone browsers.

Our engineers are working on a solution, we will update this page once we have more information.

Desktop Webmail, Mail Client & phone configurations are operating normally.

Our team are available on support@toolkit.uk if anyone has any further questions.

November 4, 2021 · 15:24 GMT

← Back