Webmail & IMAP Sending
Minor incident
Webmail
Email (IMAP)
2025-10-06 18:08 BST
· 54 minutes, 1 second
Updates
Resolved
October 6, 2025 · 19:01 BST
Open X-Change have put in a fix to return Webmail & IMAP services to normal.
We will continue to monitor this over night and update this status page if anything changes.
We’re really sorry for any inconvenience this short down time caused.
Issue
October 6, 2025 · 18:08 BST
Open X-Change have let us know they have identified 2 issues this evening.
The first, an intermittent issue with sending emails over IMAP connections, such as Outlook, Thunderbird or mobile devices.
Secondly, Webmail users may currently be experiencing timeouts when trying to log in or use Webmail in your web browser.
They are aware of these issues and working on a fix.
We will update this status page when we have more information.
We’re sorry for any inconvenience or frustration this causes.
← Back