Toolkit Broadcast Offline

Minor incident Toolkit Broadcast
2020-10-22 10:43 BST · 59 minutes, 27 seconds

Updates

Resolved

Toolkit Broadcast is now operating normally. We’re sorry for the inconvenience caused. If you have any questions please don’t hesitate to contact us on support@toolkit.uk.

October 22, 2020 · 11:42 BST
Issue

We’re aware of a problem with Toolkit Broadcast (our bulk email marketing tool) being unavailable. This service is offline as our engineers look in to it. We’ll update this page as soon as we have a solution or more information. All our other website/email/domain services remain unaffected. Please contact our team on support@toolkit.uk if you have any questions.

October 22, 2020 · 10:46 BST

← Back