Outlook (Hotmail) Email Sending

Minor incident Email (IMAP)
2021-05-12 07:03 BST · 2 hours, 2 minutes, 3 seconds

Updates

Resolved

After testing our own Outlook email accounts this morning, it appears they have fixed their server issues and Microsoft Outlook/Hotmail/Live addresses can now receive emails once more.

This appeared to be a worldwide Outlook issue that stopped hundreds of thousands of emails from sending to Outlook from lots of different email service providers, including our own.

See more info on this Outlook issue here:

https://www.techradar.com/news/outlook-down-microsofts-email-service-failing-to-receive-messages

https://www.express.co.uk/life-style/science-technology/1434840/Outlook-not-showing-emails-Microsoft-365-outage

For all those affected, please do try to resend your emails to your Outlook contacts again and let us know if you continue to receive bounce backs.

If you have any questions don’t hesitate to contact our team on support@toolkit.uk or call us on 02380 633644.

May 12, 2021 · 09:05 BST
Issue

We’re aware of an issue for our clients who are trying to send emails to Microsoft Outlook (Hotmail) email accounts.

Emails are either taking up to 5 hours to be sent or are not sending at all and bouncing back.

Our hosting provider Rackspace are aware of this and working on a fix with Microsoft Outlook directly.

We’re really sorry for the inconvenience this is causing. We will update this status page as soon as a fix has been implemented.

All other email addresses outside of Outlook are sending and being received fine.

If you have any questions don’t hesitate to call our team on 02380 633644 or email us on support@toolkit.uk.

May 12, 2021 · 07:12 BST

← Back